A-A+

PHP扩展安装mcrypt 提示没有可用包(No package php-mcrypt available)

2016年03月28日 其他 暂无评论 阅读 2,618 次

一、用CentOS的朋友基本在安装软件的时候默认都会想到用yum安装省事省时而且不会有错不需要担心依赖问题。

php大部分的扩展都是可以再yum源里安装的,但是部分扩展是没有的,需要安装epel-release这个扩展更新包。

二、也可以编译安装,虽然麻烦,但是编译的好处也是很多的,而且这个过程也是一个运维人的必修课

http://www.sourceforge.net下载Libmcrypt,mhash,mcrypt安装包
libmcrypt(libmcrypt-2.5.8.tar.gz )、mcrypt(mcrypt-2.6.8.tar.gz )、  mhash(mhash-0.9.9.9.tar.gz );

1 .先安装Libmcrypt

2.安装mhash、

3.安装mcrypt

三、在php中增加mcrypt的更新(动态加载编译)

实际上你做到上述的是远远不够的。无论你是yum安装上了还是编译装mcrypt 你在phpinfo里或者php -m 都还是看不到这个扩展,因为你还需要在php的配置文件里在配置下(我原来的php环境是yum安装的,所以php.ini的文件配置方式是不一样的。如果编译装的话 会有单独php.ini)。

下载php下的mcrypt扩展或者直接下载php的完整安装包(这里需要用到php的环境,所以需要去php的网站下载一个php的包用下,不论你的lamp环境是否yum安装)

http://cn.php.net/releases/ 网页下找到自己服务器的php版本,下载后tar解压(我的是php5.3.3)

进入ext/mcrypt文件夹

执行phpize命令(phpize是用来扩展php扩展模块的,通过phpize可以建立php的外挂模块,上面已经安装)

执行完后,会发现当前目录下多了一些configure文件,最后执行php-config命令就基本完成了

执行以下命令,确保你的/usr/bin/php-config是存在的

执行以下命令

最后的最后,会提示你如下,说明你大功告成了

顺便检查下/usr/lib64/php/modules/里的mrcypt.so扩展是否已经创建成功

然后的事就简单了,给你的php.ini添加一条extension=mcrypt.so

创建一个mrcypt.ini文件

四、重启apache,查阅phpinfo,mcrypt模块扩展已经加载

蜗牛的梦想
Copyright © Linux系统运维联盟 保留所有权利.   Theme  Ality 京公网安备11011402000199号 京ICP备14047887号

用户登录